WordPress 3.1 auf 1&1 Server

Auf einem 1&1 Server läuft WordPress nicht so gerne. Das musste ich selber feststellen, als ich merkte, dass ich keine Seiten bearbeiten konnte, der Browser sagte immer schön, dass er mit laden fertig ist aber dann ist nie die Seite zum bearbeiten gekommen. Nach dem Update auf WordPress 3.1 ging dann nichts mehr außer Fehler 500.

Hier die Lösung (1&1 Domain PHP5 fähig machen):
Lokal eine Textdatei erstellen. In diese folgendes reinschreiben:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

das ganze speicher. Dann die Datei umbenennen in

.htaccess

Diese Datei einfach ins Haubtverzeichnis eures WordPress Server hochladen.


Fatal error: Uncaught ArgumentCountError: Too few arguments to function cwppos_show_review(), 0 passed in /homepages/46/d472501950/htdocs/wp-content/themes/flat/content-single.php on line 29 and exactly 1 expected in /homepages/46/d472501950/htdocs/wp-content/plugins/wp-product-review/includes/legacy.php:18 Stack trace: #0 /homepages/46/d472501950/htdocs/wp-content/themes/flat/content-single.php(29): cwppos_show_review() #1 /homepages/46/d472501950/htdocs/wp-includes/template.php(772): require('/homepages/46/d...') #2 /homepages/46/d472501950/htdocs/wp-includes/template.php(716): load_template('/homepages/46/d...', false, Array) #3 /homepages/46/d472501950/htdocs/wp-includes/general-template.php(204): locate_template(Array, true, false, Array) #4 /homepages/46/d472501950/htdocs/wp-content/themes/flat/single.php(5): get_template_part('content', 'single') #5 /homepages/46/d472501950/htdocs/wp-includes/template-loader.php(106): include('/homepages/46/d...') #6 /homepages/46/d472501950/htdocs/wp-blog-header.php(19): require_o in /homepages/46/d472501950/htdocs/wp-content/plugins/wp-product-review/includes/legacy.php on line 18